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1 Introduction

This document explains the workflows and Dolby Vision integration in Mistika
Boutique and Mistika Ultima. It doesn’t explain what is Dolby Vision and its
components. Please consult Dolby Vision documentation for this purpose.

For a first introduction we recommend watching this tutorial, as it explains the
whole workflow from the user perspective. This document contains additional
details not explained in the video.

The Integration between Mistika and Dolby Vision is made through the CMU
Content Mapping Unit). The Dolby Vision CMU was originally based on a
dedicated external hardware unit known as “eCMU” External), but it is also
available as an internal software tool named “iCMU” Internal) integrated within
Mistika. The CMU is a Dolby Vision technology that given HDR images graded
for an HDR mastering display it will create automated versions for other target
displays of inferior capabilities (SDR displays or HDR displays with more limited
nits).

Please note that the color grading version for the HDR master monitor does not
involve the usage of any Dolby Vision tools. Dolby Vision is only used to
produce the other versions of inferior nits.

Currently, Mistika supports 2 different versions of Dolby Vision: version 2.9 and
version 4. Obviously, the version 2.9 is older than the more modern version 4,
so 2.9 is not recommended for new projects and its use is mainly focused on
projects previously created or started in 2.9. The eCMU is only available in
version 2.9, as version 4 uses only iCMU.

The initial part of this document mainly describes the workflow for the
hardware version (eCMU, as the software version can be easily understood
with the tutorial previously linked. If you plan to use the software version
(iCMU just skip the point about Hardware connections.

Dolby Vision technology has been integrated into Mistika (no additional plugins
are required), but it requires a Dolby Vision license to have access to all the
functionalities (more details in the next point).
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2 License

Dolby Vision allows the use of many of its functionalities without the need of a
license. The user will be able to configure the basic settings of Dolby Vision,
analyze the clips and export the result of the analysis as an XML or even in a
render file using the Dolby Vision MXF format.

The license is needed to create and control the different trims that are used to
adjust the color and the different deliveries for the project.

To request a license, please contact Dolby© in the following email address:
dolbyvisionmastering@dolby.com

Once the license is sent to the user, it must be placed in the following paths
(depending on the OS

Windows: C/Users/*User_name*/SGO AppData/localshared/dolby
Mac: /Users/*User_name*/SGO AppData/localshared/dolby
Linux: /home/mistika/SGO AppData/localshared/dolby
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3 Hardware connections between Mistika and Dolby
eCMU External CMU

3.1- Ethernet connection

In the eCMU, set an ip address in the same network domain as your Mistika
system and reboot the eCMU.

Once this is done, in the Mistika system open an internet browser and put the
ip address of the eCMU. This will permit testing that the network connection is
working (the eCMU GUI should appear immediately) and the eCMU GUI will let
you set up other eCMU settings (check Dolby documentation in case of any
doubt).

Note: Mistika will discover the eCMU automatically. There is no need to
indicate the eCMU ip address in any Mistika setting, just have it in the same
network. In case of problems use fixed addresses rather than DHCP. If it does
not solve the issue at least it will simplify diagnostics).
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3.2- SDI connection

Regarding the SDI cabling we will need to create three different paths: one for
the HDR mastering monitor, one for the target display and one between Mistika
and the Dolby eCMU.

The connection for the master HDR display needs to be an SDI connection
between Mistika workstation (output 1 and the HDR Mastering display.

At the date of this document the Dolby Vision workflow only supports RGB
signals. Please make sure that the video parameters at
mConfig→MasterFormats are set to RGB.

The connection for the target display needs to be an SDI connection from the
eCMU output to the target display.

The third one is the SDI connection between Mistika (output-1 and the eCMU
(input-1 and this is what can complicate things a little bit. This signal needs to
go from the Mistika system both to the HDR mastering monitor and to the
Dolby eCMU so it needs to be duplicated. This depends on the capabilities of
your video hardware but typical methods are:

● By using and SDI splitter or SDI router
● By using the monitor loop through, if available
● By using the Mistika dual link output, plus a Stereo3D effect to

differentiate both output paths. This method is normally possible in HD,
as all SDI boards can provide two outputs, but in the case of UHD you
need a video board model with 2 x Quad SDI, like the Aja Corvid88.

Once the SDI connections between Mistika and the eCMU are in place, open an
internet browser and put the ip address of the eCMU to access its GUI
interface. Check that it has detected a valid video signal and adjust settings as
necessary for your case. If the SDI signal is not detected then check that the
video parameters at mConfig→MasterFormats are set to RGB and not YUV

Note: Both Mistika and Dolby eCMU support HD, 2K, and UHD. The UHD modes
require Quad SDI connections.
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4 Working with Dolby Vision

4.1 Dolby Manager

Open the Edit→Setup→Dolby Manager window. Here you can select the CMU
mode, aspect ratio and the CM version.

The CM version will determine the metadata controls of the Dolby Vision effect
and the XML fields that will be exported. It is important to check which version
is compatible with the needs of your client (as the metadata will be different).
As we mentioned before, the latest version is version 4, so we recommend the
use of this last version and only user version 2.9 for projects started or realized
in 2.9.
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The Master Display and Target Display selection lists will also appear after a
valid CMU mode has been selected (Internal or External).

Use the Edit→Setup→Dolby Manager window to select the Master Display
and Target Display.

Master Display: Select your reference monitor (the one for which you have
color graded the images).

Target Display: These are the monitors with an inferior number of nits for which
you want to produce other versions. Please note that if you plan to make
specific adjustments for several target displays you can choose other displays
later. For the first pass you will need to start with the target display of the
lowest number of nits ( 100 nits). This is necessary for the correct interpolation
of intermediate nit formats. In that way there is a good chance that the
automatic interpolation is already valid for many of the shots when switching to
other intermediate displays, thus avoiding the need for extra manual
adjustments.

4.2 Footage preparation

Dolby Vision requires to receive the input images in a very specific format:

● Gamut: P3D65 or Rec 2020.
● Gamma:  PQ EOTF ST.2084

To manage the output color space of your project to match the required signal
for Dolby Vision, make sure you use a Unicolor node or an ACES ODT node
selecting the right output for your stack.

Make sure that all the color journey, and the master finishing process is done
BEFORE applying the Dolby Vision effect. Do not apply any subsequent
effects or display filters that could alter the image content after the Dolby
Vision effect otherwise the output images, SDI signals and XML metadata will
be invalid for Dolby Vision workflow. The Dolby Vision effect MUST always be
the LAST colour transformation, as shown in the following image.
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The same can be said about Framing effects. The Edit→Setup→Dolby
Manager tool provides its own settings to define the image aspect ratio and no
framing operations should happen after the Dolby Vision effect. Any
subsequent cropping of parts of the image would invalidate important
calculations like the Average Brightness and others.

Obviously, all colour grading and finishing effects also need to be applied
before the Dolby Vision effect.

If there are cross fade effects, make sure that each clip has its own Dolby
Vision effect applied, then just apply the Mix on top as usual, and Mistika will
automatically produce the correct interpolation between both Dolby Vision
effects. Do not apply a Dolby Vision effect to the Mix effect.

Please note that the Dolby Vision effect is only needed to produce alternative
versions for other target displays, not for the HDR mastering display.
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4.3 Image analysis with the Dolby Vision effect

The next point we will assume you have already finished your HDR grade for
the HDR mastering display.

Now apply a Dolby Vision effect to each shot as the last effect in the stack
(upper track).

Check that the TargetID field is set to the same target display that you have
selected in Edit→Setup→Dolby Manager in order to monitor the result. The
most typical case is setting the result to 100nits BT. 709 BT. 1886, as the
normal workflow is to create an SDR version from the graded HDR master.

In the Dolby Vision effect, set Analysis→Perform Analysis parameter to
Perform. The image will change to shades of yellow. This is just to warn you
that the Dolby Vision effect is already active, but the shot has not been
analysed yet for the whole duration of the effect.

The effect needs to calculate the maximum, minimum and average brightness
of the shot for which it needs to go through all the frames. To do this just
press VisualEditor→Playback.

In order to make this operation across several clips, set the Perform Analysis
to Perform, select Perform Analysis and Analysis State and Propage both
values by any of the Propagate options. Then set the Playmarks selecting
those clips and Play the timeline to analyze all the shots in one go.
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When it finishes the Analysis State parameter will automatically change to
“Completed” state and the image output sent to the target display will be
already calibrated. The picture below shows a Before Analysis pending) / After
analysis  example.

At this point the output images in the target display should have changed
noticeably. They should already look “technically correct” for that particular
target display. They may still need some manual “trim” adjustments (which will
be done in the next section) but the improvements in brightness should be
already very noticeable.

Note: If nothing changes or if the overall brightness has not improved then
check the steps in the previous sections, specifically that the Dolby Manager
has the same target display as the TargetID of the effect.

4.4 Manual adjustments using trims

After the automatic analysis is done, now go to the Trim 1 parameters layer.
With these parameters you can do additional subjective adjustments. In many
shots you probably will not need to make any further modifications, but when
you still appreciate noticeable differences between the target display and the
master HDR display (apart from the differences purely related to the
capabilities of each display) then you can use the trim parameters for fine
tuning or to trade off and prioritize the most important subjective aspects. The
objective here is to match the target display to the mastering display as much
as possible. Please check the Dolby Vision documentation for more
information about each parameter).
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Depending on the Dolby Vision version selected in the Dolby Manager, the
interface for managing the trims will change. In version 4, there is a Color GUI
dedicated for each trim, meanwhile in version 2.9 the controls are restricted to
the traditional editor available in all Mistika effects.

Note: When using the eCMU the images in the visual editor will not change. In
this mode the changes are only shown in the target display. This is because
the colour transformations are applied in the eCMU device and then sent to the
target display from there. As a difference, in the iCMU the changes are also
shown in the Visual Editor, as in this case the iCMU is a software device in the
local system receiving the images from Mistika and returning the output images
to it.
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4.5 Adjusting additional Target Displays

Dolby Vision capable displays provide automatic adjustments in the range
between the target display and the HDR mastering display (they can read the
Dolby metadata embedded in the images and interpret the images data
accordingly) . However, if you want to make specific adjustments for
intermediate displays that are especially important for you then you can add
more adjustment layers as follows:

Select Visual Editor→Layer→Add Layer

A new trim layer will appear in the Dolby Vision effect. Set its TargetID to the
new target display and also select it in Edit→Setup→Dolby Manager to switch
the CMU to the new target. Then repeat the trim adjustments as necessary for
the new target display.

Please note that even if the effect can store the transformations for multiple
target displays the CMU can only produce one target display at a given time.
For that reason, when the Dolby Vision effect is not set to the same target
display as the Dolby Manager it will not show any changes (it will simply show
the input images).

Also note that the Dolby Vision effect does not have any setting to choose
which one is the active layer (active TargetID, because that is precisely what is
decided in the Edit→Setup→Dolby Manager tool as explained.

It is also important to not apply any posterior modification to the image
output (image scalers, LUTS, etc), as the Dolby Vision metadata is encoded
embedded within the image data using proprietary technology, and this
metadata can be easily destroyed if the image is modified by non Dolby Vision
aware processes.
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4.6- Final Render and Dolby Vision XML export

Before rendering, make sure that there are no empty areas in the timeline.
Dolby Vision XML does not support this case. To cover an empty area you can
use a Solid effect, then apply a Dolby Vision effect to it and analyze it (or copy
it from elsewhere).

When rendering, select Output→Render→Dolby Vision HDR Master→Dolby
Mezzanine J2K, Tiff or EXR as the render format and render your work. This is
the official master format for Dolby Vision.

By using this format, the rendered file will include all the metadata produced by
the Dolby Vision effect embedded.

You can also render to other formats that do not have embedded metadata and
then deliver an XML file with them. In that way the Dolby Vision master can be
produced later in other systems. But if you use a different format (rather than
Dolby Vision mezzanine) make sure you select a render format with at least 12
bit per channel (EXR, Tiff16, etc). Otherwise it will not be Dolby Vision
compliant.

To create the XML file, select all the shots that you want to include (all the
Dolby Vision effects) and press Mistika→Edit→Macros→Dolby Export. This
will create a Dolby Vision XML file with the Dolby Vision metadata for all the
selected shots. This file is placed in the OUTPUT folder of the project.
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A single Dolby Vision XML file can contain as many shots as you want. In a
certain sense, it is somehow similar to an EDL but also containing  all the HDR
metadata.

4.7 Importing a Dolby Vision XML file to Mistika

A Dolby Vision XML file can also be imported in a Mistika Timeline (just drag &
drop the XML file to the timeline). When it is done, a collection of Dolby Vision
effects will appear in the correct positions and durations of the Timeline
(similar to an EDL which can then be applied to the original shots.

If the imported XML doesn’t match with the settings selected in the Dolby
Manager tool, a pop up window will appear asking to automatically change
those parameters following the metadata contained in the XML. The same
behaviour can be expected when importing the Dolby Vision mezzanine file into
the TimeSpace.

Mistika does not allow to mix Dolby Vision effects from different versions (2.9
and 4, no matter if those effects were created from the FX panel or imported
through XML or with the Dolby Vision mezzanine clip.
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