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Introduction to Mistika Review 
 
Mistika Review​ is a an application to playback and review digital images of any format. It 
permits to take notes (both text and drawings on the images) and it supports most formats, 
including the ones from high end cameras and typical VFX formats, with advanced color 
management  and superior realtime playback capabilities. 
 
Main features: 
 
Very intuitive and easy to use. 
 
Realtime playbacks for raw footage from high end cameras (Red, Arri, Sony, Canon,...) and 
VFX formats (DPX, EXR, J2K... ) plus a myriad of common formats (Prores, mxf,  mp4  H264 
/ H265/HEVC, ... ). The complete list is available in the “Read formats” section of this 
document): 
 
https://support.sgo.es/solution/articles/1000236984-mistika-ultima-supported-file-formats-full-
compilation- 
 
 
Advanced color management with dedicated color controls per clip, per segment, and per 
timeline. Apply any combination of LUTs , gamma curves and color gammuts as required. 
 
Support multiple versions / multiple cameras / multiple layers per segment. 
 
Support multiple resolutions and multiple playback speeds on the same timeline. 
 
Provides overlays with all the important metadata of the shots 
 
Support modern image formats like Stereo3D, VR360, HFR, HDR, UHD, and modern color 
standards like 709, P3, 2020, XYZ, ACES, etc.  
 
 Multi-platform Windows / Mac / Linux  
 
Dockable interface that can be adapted to the aspect ratio of the images, to give the images 
maximum real estate.  And with a full screen presentation mode readily available with a 
double click. 
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Installation and configuration 

Installation 
 
First create your account at ​www.sgo.es​ (make sure to confirmation link that will be sent by 
email) 
 
Choose your plan at  ​www.sgo.es/products/​  , then download the software installer, execute 
it and follow instructions. 

Licensing 
 
https://support.sgo.es/support/solutions/folders/1000228284 
 

First launch of Mistika Review. 

 
When you first launch Mistika Review you will be prompted with the SGO Software License 
Agreement. 
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To read the all license agreement you can scroll using the scroll bar to the right. To access all the 
features of Mistika Review you will have to Accept the Software License Agreement. If you don’t want 
to be prompted with this windows again turn on the Don’t ask me again option at the top of the 
window. 

 
 
Once the License Agreement is accepted Mistika Review will launch. 
In the first launch Mistika Review will launch the factory default window layout. 
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The Mistika Review interface 

 

The Window menu and the dockable panels 
The interface is divided in specialised panels that can be hidden, resized, or moved to other 
places as needed. 
 
Window->Panels: ​ Before starting a session it is a good idea to adjust the Mistika Review 
interface to your particular needs, like you would do with the driver seat when going into your 
car.  Hide any panels that you will not need for the next session to get more space for the 
images, and try to match the interface for the  aspect ratio of your images.  For example 
many content will not need the ​Review controls​ panel at all (or not temporally).  Also note 
that  the ​Storyboard ​panel can be easily hidden or shown with the ​S ​hotkey, and it also has 
a dedicated zoom menu to control the icon sizes.  
 
Window->Layout : ​When you are satisfied with the current interface layout, this menu 
permits to ​save / load​ the layout as a preset. This menu also has a ​Reset ​option to come 
back to default layout, in case you get lost. 
 
Window->Auto hide panels:  ​Provides ​panel tabs ​at the upper right corner of each panel 
that can be drag & drop to other places of the interface. They are shown as green labels at 
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the upper right corner of each panel (see picture below), and they can be manipulated  as 
follows: 
 

Drag the separation border ​between panels to resize them 
 

Drag and drop a panel tab close to the desired border ​to move to it (the candidate 
destination area will be highlighted during the operation).  
 
Drag & drop a panel in the interior or another panel ​to share the same panel. This 
will create control tabs for each panel in the top left corner of the panel, to control 
which one is shown at each moment. 
 
Drag & drop a ​panel tab ​to the outside of the application window​ to create an 
independent floating window with it (for example if you are working with multiple 
monitors).  

 
 
For example, if your images are panoramic you may prefer to move the ​Clips stack​ and the 
Notes Editor​ panel below the visual editor, to get all the horizontal space for the images. In 
this example, the ​Notes Editor ​has been moved to the bottom right corner, while the ​Clips 
stack ​and the ​Review Controls ​are sharing a same panel controlled by their panel tabs at 
the top left corner of the panel. Meanwhile, the ​Storyboard ​has been hidden (using the ​S 
hotkey). 
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Full screen presentation mode 
A double click on the main image of the Visual Editor will switch back and forth to ​full 
screen presentation mode​, which only shows the clip content at full screen and with no 
borders. 
 
In the full screen mode you can still use the all the ​playback and navigation hotkeys​, 
zoom In / Out​ by using the vertical arrows keys (or mouse wheel), and the ​panning 
controls​ by dragging the pointer with the right mouse button.  
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The Clips Stack 
 

Clips stack panel 
 
This panel will hold a stack with all the clips of the current segment / current shot.  There are different 
reasons to have multiple clips per segment: They can be different versions of a same shot, multiple 
layers of a composition, or to cover other user needs.  
 

 
 
To the left of every clip there’s a Clip Number. These numbers will help to quick access the clips in the 
Viewer using the hot key numbers from 1-9. 
 
Stereo pairs are shown as just one clip, with a ​L:R ​indicator at the right of the clip name.  
 
Clips in the clip stack can be reordered by dragging the clip over another clip in the stack that you 
wish to replace the position of. 
 
The panel will have three different Clip Icon view modes at the bottom: 
 
No Icon: 

   
 
Small Icon: 
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Large Icon: 

 
 
The clip will show the original clip name, the native frames per second & resolution. 
 
By right-clicking over a clip you get a contextual menu: 
 

 
 

Add Media,​ will open the ​Load Media Window  
 
Remove Media, ​will remove the selected clip from the clip stack. 
 
Remove All Media​, will remove all the clips contained in the clip stack. 
 
Move Up​ will position the selected clip one position up. 
 
Move Down​ will position the selected clip one position down. 
 
Clip properties ​will open a properties panel explained in the next point. 
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Clip properties panel 

This panel is accessed through the ​contextual menu​ of the ​Clips Stack panel​. 
 
Clip Properties shows the properties of the current clip that is being viewed. The information is 
separated in File information & Clip information. 
 
In File information you can see is File Name, Path, Size, Creation Date & Modified Date.  
 
In Clip information you will find Metadata of the clip and information related to the image and the 
sound. 
 
The Metadata information you can find here is: Tape Name, Tape Header, Timecode, FPS, 
Interlaced, Frames, Tracks, Comments. 
 
The Image information you can find is: Resolution, Aspect Ratio, Codec & Format. 
 
The Audio information you can find is: Codec, Sample Rate, Channels & Bit Depth. 
 
 

Synchronization behaviour between multiple clips of the same 
stack 
 
Edit -> Preferences -> VisualEditor -> PlaySync: ​Defines how to synchronise between the different 
clips of a same shot (segment) when jumping from one to other, so no matter if they have different 
durations or timing rules you will be go to the frame that is intended for the same particular moment of 
time. It can have these values: 
 

None ​(default)​:​ ​No sync attempts are made. Instead, each clip will remember the last 
position, so you go to the same frame as the previous time that you worked with that clip. 
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Frames: ​When selecting a new clip go to the same frame number as in the previous clip. 
Timecode is ignored,. 
 
Timecode: ​When selecting a new clip go to the same source timecode as in the previous clip. 
Frame number is ignored.   
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Review Controls 
 
Note: This panels is hidden by default. You can show it in the ​Window->Panels->Review Controls 
menu. 
 
The ​Review Controls ​are actioned at three different levels. Clip level, Segment Level and Global 
Level. 
 

 
 

Clip Level:​ Only applied to the selected clip 
 
Segment level:​ Applied to all clips appearing in the clip stack for the current segment (current 
shot) 
 
Global level:​ Applied to all clips from all the segments of the timeline. While the previous 
depend on clip content, these controls are intended as temporal visualization controls for the 
current display model and temporal visualization mode prefered by the user..  
 
Note:​ In early versions of ​Mistika Review​ the ​Global​ controls were located in this panel, side 
by side with the ​Clip ​and ​Segment ​controls.  But at users request they are in the process to 
being moved to a dedicated location in the ​Visual Editor top bar ​for more convenient 
access.  Depending on your software version you may still find them in both locations, but 
they are the same. We recommend to use the set in the  new location at the ​Visual Editor 
top bar 
 

 
Review Controls​: 
 

 
 
Lift,​ ​Gamma​ & ​Gain ​are at the top. These color adjustments are based on ASC CDL standards. 
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Following are the Stereo3D controls:  
 
Convergence​: this parameter will adjust the interaxial of Stereo3D clips. 
 
Left FW, Right FW​:​ This stereo adjustment will add​ Floating Windows.  ​In a Stereo3D pair, a 
“floating window” creates the optical illusion to bring the screen frame towards the spectator, by 
changing the borders of the image. This is typically used to avoid visual fatigue due to conflicting 
depth (the screen frame is perceived to cut off the content, so it needs to be perceived closer to the 
viewer than the image content). This means that it may need to be adjusted for the particular display 
that you are using for the reviews. 
 
Next are the parameters to define color transformations. 
 
Input Curve​ is the incoming gamma curve. It’s important to define this correctly to achieve accurate  
Input Curve  
 
Input Gamma​: Color space attributes of the incoming clip. This has to be manually adjusted to 
perform color transformations. 
 
Output Curve Output Gamma​: Color Space attributes for outgoing color transformations. This has to 
be manually adjusted. ​ In case of outputting to ACES Color Spaces set linear light and XYZ color 
gamut. 
 
Aces Output Space​: ACES ODT transforms. It is necessary to set the correct Input Curve and Input 
Gamma of the clip. 
 
Lut 1D / Lut 3D: ​To apply Lut1D and Lut3D files. 
 
Geometric transformations​: ​Scale X/Y​, ​Offset X/Y​, and ​Crop Left/Right/Top/Bottom 
 
NOTE: ​What you adjust here are the general controls that you consider necessary for the source 
clips. In addition, the ​Visual Editor​ has its own color controls to adjust for the local display. to provide 
more flexibility with a second level of adjustments. 
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Notes Editor 
 
The ​Notes Editor ​in the factory default layout is positioned to the right of the screen. From here you 
can manage everything related to the notes that are added during a review session. 
 
The panel has a menu on the top where you can add a new note, activate the brush to draw over the 
image, and choose the color you want to draw the stroke with. 
 
The “​+​” icon will create a new note in the panel and it will also add a marker in the timeline in the 
corresponding time code. Mistika Review will automatically create the note with a name “Note 01” . All 
following notes will have a name with a note number increment (eg. Note 02, Note 03,...). But the 
name of the note can be modified if the user wishes (double click of the note name) 
 
 
                                                        Drawing overlays                        Notes Editor 

                                                     ​Time bar note marks 
                                                      (for note navigation) 
 
 
The user can choose to draw a stroke over the image. The ​color of the stroke ​will be selected in the 
Drop Down Menu beside the Note’s Name. The color of the stroke can be changed after the drawing 
by changing the color selected in this drop down menu. 
 
The ​Eraser ​Icon will delete the last stroke drawn over the image. If more of one stroke is drawn the 
user will have to click the eraser several times until all the strokes are deleted. 
 
The “X” icon will ​Delete ​the whole note. Mistika will ask you to confirm the deletion if you don’t want 
this message to appear again in the Session (tick the “Don’t Show Again” option)  
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Visual Editor 
 
The visual editor is the panel where most of our attention and work will be focused on. It’s over here 
where the video files will be played. The panel has menu bars on top and bottom of the panel. Each 
menu bar is dedicated to different operations. The bottom menu has all operations that are dedicated 
to shuttle and navigation purposes, and the the top menu bar is dedicated to the Viewer Controls. 
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Visual Editor top menu bar 
 
Stereo3D   VR    Channels      Color Management                                  Gamma controls 

 
The above picture provides a schematic view with all the submenus opened. 
 
Among other controls, this top bar provides ​Global color controls. ​These controls​ ​are 
independent of the ones in the ​Review controls ​panel​ ​for the current segment and selected 
clip, which are applied before the global controls.  
 
As a difference, the ​Global ​controls are not mandated by the image content. Instead they 
are normally dependent on the current display model that is in use, and in the current 
visualization mode that the user selects for temporal use.  
 
Note:​ In early versions of ​Mistika Review​ the ​Global​ controls were also located in the 
Review Controls​ panel, side by side with the ​Clip ​and ​Segment ​controls. But at users 
request they are in the process to being moved to this dedicated location in the ​Visual 
Editor Top bar​.  Depending on your software version you may also find them in the ​Review 
Controls ​panel (explained in the previous section) but they are the same. 

Stereo3D modes 
Select the 3D visualization mode. The anaglyph modes permit to use Cyan/Red glasses for 
Stereo3D visualization on any display. The interlaced, Side by Side, and Top & Bottom 
modes permit Stereo3D visualization with displays and glasses supporting those specific 
modes (when in full screen mode).  
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VR mode 
Converts VR360 equirectangular images, also opening an VR overview panel for navigating 
through the virtual environment. This panel provide controls for focal length, to control the 
sensitivity of the mouse, and to recenter the view point. 

Channels 
Provides independent visualization of RGBA channels 

Color Management 
Permits to apply and ​Output Curve​, an ​Output Gamut​, and a ​LUT ​( 1DLUT or 3DLUT) 
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Visual editor contextual menu 
 

 

Load Media 
Load media files, explained in ​File management​ chapter. 

Show info 
Provides image overlay with clip metadata: filename, timecode, native fps and resolution. 

Skip Frame 
Force the playback to keep the target fps speed by skipping as many frames as needed. 

 

Timeline bar 
 
The timeline bar has all the navigation and playback related functions.  
 

 
Note Nav.       Edit marks                                                           Shuttle and playback controls                            Zoom 
Proxy  
 
Next sections explain all the controls in more detail, from left to right: 
 

Notes navigation  
 

Note marks:​ As a reference, each note leaves a mark in the time slider with its own 
colour. (an orange mark and a yellow mark in the example picture) 
 
Previous Note ​/ ​Next Note: ​The are the two green icons with arrows. By Default 
Mistika Review starts with navigation active for all notes, but you can also select a 
color in the ​Notes Color Ball ​to restrict navigation to notes of a particular color.  
 
Notes duration: ​This field is defined in ​Edit -> Preferences -> VisualEditor -> 
Notes duration​,  and it control the duration of the note drawing overlays during a 
playback (to give the user enough time to appreciate them during the playback). In 
any case, a crossfade is also applied for smooth appearance and disappearance of 
the notes, which also avoids eye strain during stereo playbacks. 
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Timeline navigation and playback controls 

 

 
   Edit marks   Contextual  menu          Shuttle                   Loop      TC          Playback Speed 

  

Edit marks  
They restrict the time range to playback, and they appear as yellow marks on the timeline. 
The yellow icons on the left are shortcuts to ​Set In / Out ​points and to ​Go to In / Out​. 
 
The contextual menu in the Timeline bar offer the same controls and additional options, to 
Remove Edit Marks​, and to ​Clear Cache ​(the cache is described ​later​)​.  
 

Shuttle  
It works as the shuttle of any video applications. With controls to go to ​Previous / Next Clip​, 
Previous / Next  Frame, ​and ​playback ​in both directions​. 
 

Playback mode  
to select between continuous playbacks or to ​loop ​the current shot. (The continuous 
playback will pass through the next clips, but it can also be limited with the ​Edit Marks ​as 
said). 
 

Speed controls 
 

FPS  
Defines the target playback speed, in frames per second. The ​Source​ ​value will try to read 
the ​native fps​ metadata from the clip (if it is available), and its other values will permit to 
select between  the speeds of common video standards.  
 

Speed factor  
This permits to accelerate or reduce the playback speed temporally by a selectable factor. 
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Zoom & Pan controls 
          ​Zoom controls​            ​Proxy

 

 
Zoom In/Out​ (also available with mouse wheel or vertical cursors) 
 
Zoom Reset ​(zoom 100%) 

 
Zoom Center ​(Center image on ​Visual Editor​ panel) 

 
Zoom factor​ (10% to 1600%) 
 

Proxy mode 
It is the rightmost button in the bar. Activates a low resolution mode 
for faster scrubbing and playbacks when working with complicated 
formats. 
 
The resolution division factor is configured in ​The Edit->Preferences->Performance panel 

Time range zoom controls 
The time range controls at the sides of the time bar permit to zoom in time and move through 
it with a scroll bar, for accurate control at frame level and for long format shots that need 
more time detail  
 
 

 

 

 

RAM cache indicators 
 

 
 
The RAM cache indicators are little green dots indicating the frames that are already cached 
(to help on realtime playback performance). It is described in the ​Performance Options -> 
RAM cache   
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Storyboard: 
 

 
 
The Storyboard provides an iconic representation of all the shots in the timeline.  
 

Storyboard navigation  
 
To go to a shot by just click on it. You can also use the usual navigation hotkeys ​Ctrl + -> 
and ​Ctrl + <-​ ).  
 
To scroll through the Storyboard just ​drag with right mouse button 
 

Storyboard contextual menu  
 
Provides tools to ​Clone Shot, Delete Shot, Load Media, Show Source Timecode 
(deactivated by default), and ​Zoom controls ​(to use larger or smaller icons)  
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File management 
 

Load and saving Review sessions 
The ​File ->Load ​and ​File->Save / Save us ​menus will load and save the current review 
session, which is stored in a Mistika ​.env ​file.  
 
It is in important to remark the ​File ->Load ​ menu can not be​ ​used to import media files, 
which is a different process explained in the next points. 
 

Using external file browsers to import media 
 
The easiest way to load new media is to drag & drop files (or complete folders) to the ​clip 
stack​ (to load media for the current shot) or to the ​Storyboard ​(to load each clip as a 
different shot) 
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Advanced mass import (folder hierarchies with multiple shots 
and multiple versions for each one) 
 
For importing a folder hierarchy in one go you can  drag & drop the parent folder, and the 
following rules will be used: 
 
First level of hierarchy (folders directly in the base folder) are considered to belong to 
different segments. A new segment is created for each of those folders 
 
In the second hierarchy level, clips appearing in a same folder are considered to belong to 
the same same segment, so they will appear on the same stack. 
 
For the case of enumerated sequences, you can have each sequence in a third hierarchy 
level (one sequence per folder), and they will also go to the same segment stack. 
 

Using Mistika file browser to import media 
The Mistika ​File Browser​ provides additional capabilities to what is found in standard  OS 
browsers, and it also permits to previsualize advanced codecs not understood by the OS.  
 
A main difference is that it is project-centric, because it is also designed to collaborate in a 
Mistika Project ​with other Mistika applications and to review their assets and timeline files. 
(Users without  this need will find some empty metadata fields and some extra tools with no 
purpose for them, just ignore them).  
 
Note​: The browser tools for managing Mistika Ultima assets and its metadata are not 
explained in this document but in the ​Mistika Ultima ​manual. 
 
Panels containing media (​Clip Stack​ and ​Storyboard / Visual Editor​) provide and ​Add 
Media ​button in their contextual menus to open the Browser and import media to that panel 
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Most functions are trivial as in any file browser and are not commented here. But some 
interesting tools are: 
 

Metadata floating window 
Putting the pointer over a filename will show all the metadata that it can extract from the clip 
in a temporal floating window. (see above picture) 
 

Source Monitor 
At the right side there is a source monitor that you can previsualize the selected media file.  
 

Import functions 
To import media,​ double click ​on a file, or use the ​Load​ icon if you have a multiple 
selection. You can also ​drag & drop​ a media file or a complete folder of media files to the 
desired panel.  
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Filter 
Type any string in this field to only see the filenames containing it.  
 
At the top right corner there is also a switch to commute between ​All Files​ or ​Supported 
media files​ only. 
 

Paths bookmarks panel 
Accessed through the contextual menu ofthe 
Folder Tree ​title bar 
 
You can drag & drop files or folders to create 
bookmarks with them. The purpose is to 
provide fast access to locations that you need 
to use often. 
 
It also has its own contextual menu to manage 
the bookmarks.  
 
 

Selection bookmarks panel 
Accessed through the same contextual menu 
of the ​Folder Tree ​title bar, and It works in the 
same way. , But this panel is oriented to 
remember ​multiple selections ​of files or 
folders.  
 
Shift click or Ctrl click to create a multiple selection.  Then drag & drop the selection to the 
Selection Bookmarks​ panel to create a bookmark. 
 
 Later,  just click on the bookmark to find the original folder and reselect the same 
combination of files. Or just drag & drop the selection bookmark to the desired panel in the 
Mistika application. 
 

Stereo3D filenaming pattern 
 
Mistika can detect the media files for each eye and import them accordingly. But it needs to 
know what is the label to identify each filename. By default it searches for “LEFT” and 
“RIGHT* strings, but you can configure it in this setting:  
 

26 



 

Edit->Preferences->Import->Stereo3D 
 
You can also add more strings (​comma separated​) to detect more cases. Example:  
 
LEFT,left,_L_ 
 
Once this field has been setup to match your filenames, then you can import a stereo pair by 
just double clicking in one of the eyes in the ​AddMedia->Mistika Browser ​panel, and the 
other one will be detected and imported automatically. 
 
In the stack panel, stereo pairs are shown as just one clip with a L:R indicator at the right of 
the name. 
 

File integration with other Mistika applications 
Mistika Review will support to open Mistika assets in general ( .lnk, .rnd, .env, .vrenv, ... ). 
Thus extending the Review capabilities to complex timelines with effects, not only media 
files. 
  
In general, the effect compatibility requires to use Mistika products of the same version. 
Although in the particular case of Mistika Review you can also load projects from the 
previous version of other applications. At the date of this document, Mistika Reviews 8.8.7 
can read projects from MistikaVR versión 8.8.7 and Mistika Ultima 8.7.0.  (Mistika files 
including .vrenv, .env, .lnk, .rnd…) 
 
If you are directly reviewing media files from Mistika Ultima (rather than loading its timelines 
or .env files), then it is recommended to  import the media by navigating to the Mistika .lnk 
files under the DATA folder of the project rather than importing the original media files again. 
This is because the .lnk files have already analysed all the metadata of the media files, and 
this makes the import much faster, also supporting iconic representations of the images in 
the Browser. 
 

File integration with third party applications and databases 
The review sessions can be saved with the ​File->Save​ menu. This creates a ​.env​ text file 
using the ​Mistika Syntax,​ which is easy to understand for programmers who need to create 
integration scripts with other applications in both directions.  
 
In this way you can write .env scripts to prepare review sessions that can be loaded in 
Mistika Review, or to save a review session and read the content from the ​.env ​text file to 
integrate the notes metadata with other applications. 
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The easiest way to learn this syntax is to save some examples and read the files, which 
should be enough for basic reviews.  For more complex work, the ​.env syntax ​is explained 
in more detail in this document: 
 
https://support.sgo.es/support/solutions/articles/1000237044-mistika-scripts-syntax-as-found
-in-env-files- 
 
In addition, SGO is also working in other integration tools for next versions. Stay tuned… 
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Performance considerations and optimizations 
 
 

RAM cache 
 

 
 

Cache indicator 
The little green dots in the time bar represent the frames that are already loaded on RAM. 
The first playback can be slow when using difficult formats, but once the images are loaded 
a first time they are kept on RAM cache for successive playbacks, which permits realtime 
playbacks for very complex formats.  
 
Once the available RAM is exhausted the oldest frames will be removed from the cache 
automatically, to get space for next frames. 
 

Cache configuration 
The amount of RAM cache is defined in ​Edit -> Preferences -> PerformanceOptions -> 
MaxCacheMemory​.  
 
Please be careful not to exceed the system limits, otherwise the system will become 
extremely slow at some point (due to RAM “swapping”), or it can even crash. Also, if you 
adjust it to high values we recommend to close all the other applications that could be 
opened.  
 

Clear cache  
The ​contextual menu of the time bar​ provides a​ Clear 
Cache​ option, to permit a  flush cache action, typically 
used to refresh when some of the cached images have 
been changed by other collaborating applications. 
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Recommended hardware configurations 
 
Mistika Review is designed to run even on the smallest computers. But it will also use all the 
resources that you can throw to it. These are the important bits: 
 
RAM: ​If possible,​ ​Install ​enough RAM as to permit to cache the longest shots​ that you plan to use. 
 
GPU: ​It is​ ​Important for ​high resolution ​displays, also for the color and framing processing of the 
Review Controls, ​and also for decoding some ​codecs ​(R3D…).  
 
Uncompressed formats ​(DPX, EXR uncompressed, Tiff16..)​:​  Use  ​storage devices as fast as 
possible ​(SSD NVMe or disk arrays), and try to use local copies rather than using cloud storage. For 
complex cases, please note that SGO provides storage solutions that permit to playback up to 8K 
uncompressed in realtime. 
 
Compressed formats ​(EXR compressed, H264/H265, R3D, Prores ..,):​ ​Those formats mainly 
depend on the ​CPUs ​of the system, although in some cases the ​GPU ​is also used. We recommend to 
use the OS task manager or similar tools to study where are the hardware bottlenecks for your 
particular case. 

The Edit->Preferences->Performance panel 
 
In the next picture it is shown in expert mode (required to access all the options) 
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Max Cache Memory 
 Explained in the ​RAM cache​ point. 

Low Resolution Ratio (for Proxy mode) 
The resolution division factor when working in ​Proxy Mode​. (The proxy mode is at the rightmost icon 
of the time bar) 

CPU Cores 
It should be configured to the number of CPU threads of your system. This setting only applies to the 
processing of Mistika effects, so for normal reviews it has less importance than the next points (IO 
Threads and Pipe Units).  Reduce it if you want to limit the number of cores that the application can 
use. 

IO/Threads 
Number of frames that are decoded in parallel. Normally set to the number of CPU threads. Reduce it 
in case of instabilities due to the lack of enough RAM.  

Pipe Units 
Number of frames that are read from disk in a same IO operation. In general it is recommended to 
match the number of IO/Threads and CPU threads. Reduce it for very high resolution images.  
 
You can also reduce these values for smoother playbacks when the system is not powerful enough to 
playback your media in realtime.  
 
For example, if PipeUnits is set to a high value in a system that is not capable for that, let’s say 
PipeUnits = 24 frames. Then it will read a packet of 24 frames and decode them, playback those 
images in realtime, and then it will be stuck for a moment while waiting to finish reading the next 
packet of 24 frames that was happening in the background. When finished it will play another 24 
frames and wait again..). In situations like this it you can get a more constant playback by reducing 
these values to match the system capabilities. 
 

Use Backload buffers 
If switched off it will deactivate the whole read ahead and background decoding pipeline, which also 
means to destroy all the realtime capabilities of the application.  Only recommended to switch off 
when working with very high resolution images on systems that do not have enough RAM resources 
for proper work. So it provides a way to save RAM for formats that the system cannot playback in 
realtime anyway and make it crash due to the lack of enough RAM.. 
 
 
 
 
 
Enjoy Mistika. 
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